ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  The Analyst em Qui 11 Ago 2011 - 5:38

10/08/2011 -VISUALG

1º EXERCÍCIO
ELABORAR UM ALGORITMO QUE DADAS DUAS NOTAS DE UM DETERMINADO ALUNO, CALCULE A MÉDIA ARITMÉTICA E IMPRIMA O NOME DO ALUNO, AS NOTAS E A MÉDIA.

RESPOSTA
algoritmo "1º ALGORITMO"
// Função :MÉDIA ARITMÉTICA
// Autor : TIAGO DE ABREU
// Data : 10/08/2011
// Seção de Declarações
var
N1,N2,Ma:real
Na:caracter
inicio
// Seção de Comandos
ESCREVA ("DIGITE SEU NOME ")
LEIA (Na)
ESCREVA ("DIGITE SUA 1ª NOTA ")
LEIA (N1)
ESCREVA ("DIGITE SUA 2ª NOTA ")
LEIA (N2)
Ma <- (N1+N2)/2
ESCREVAL (Na )
ESCREVAL (" 1ª NOTA=",N1)
ESCREVAL (" 2ª NOTA=",N2)
ESCREVAL (" MÉDIA=",Ma)
fimalgoritmo

PERCEBEU QUE AO INVÉS DE DIGITAR O COMANDO "ESCREVA" EU DIGITEI "ESCREVAL", VC SABE O PORQUÊ?
RSRSRS!!!! COMO OS ÚLTIMOS COMANDOS SÃO REPETIDOS PRECISEI DIGITAR "ESCREVAL" ASSIM CADA INFORMAÇÃO OCUPARÁ UMA LINHA:
EXEMPLO:

DIGITE SEU NOME TIAGO
DIGITE SUA 1ª NOTA 3
DIGITE SUA 2ª NOTA 4
TIAGO
1ª NOTA= 3
2ª NOTA= 4
MÉDIA= 3.5


CASO CONTRARIO FICARIA ASSIM:

DIGITE SEU NOME TIAGO
DIGITE SUA 1ª NOTA 3
DIGITE SUA 2ª NOTA 4
TIAGO 1ª NOTA= 3 2ª NOTA= 4 MÉDIA= 3.5


avatar
The Analyst
Admin

Mensagens : 18
Data de inscrição : 31/07/2011
Idade : 34

Ver perfil do usuário http://theanalyst.xpg.com.br

Voltar ao Topo Ir em baixo

Site legal de algoritmos....

Mensagem  Tiago de Abreu em Qui 20 Out 2011 - 0:10

acesse: Site sobre VisualG Basketball

mostra alguns recursos legais.... abrindo mais as possibilidades de criação....

avatar
Tiago de Abreu
Ameba²
Ameba²

Mensagens : 25
Data de inscrição : 22/08/2011
Idade : 34

Ver perfil do usuário http://www.vlogdourbano.xpg.com.br

Voltar ao Topo Ir em baixo

Resolução Exercício 40 Apostila Pag 31

Mensagem  Tiago de Abreu em Qua 23 Nov 2011 - 20:24

Exercícios
40- Escreva um algoritmo para calcular o reajuste salarial de uma empresa com 100 funcionários, de acordo com os critérios:
- os funcionários com salário inferior a 10.000,00 devem ter um reajuste de 55%;
- os funcionários com salário entre 10.000(inclusive) e 25.000,00(inclusive) devem ter um reajuste de 30%;
- os funcionários com salário superior a 25.000,00 devem ter um reajuste de 20%.

Código:

algoritmo "Exercício 40 Pág 31"
// Função : Lista de Repetição
// Autor : Tiago de Abreu
// Data : 23/11/2011
// Seção de Declarações
var
funcionario:inteiro
s_atual,s_novo,reajuste:real
inicio
// Seção de Comandos
escreval (" $$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$")
escreval ("                            REAJUSTE SALARIAL 1.0                              ")
escreval (" $$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$")
enquanto funcionario < 100 faca
funcionario <- funcionario + 1
escreva ("  Digite seu salario Atual: ")
leia (s_atual)
se (s_atual < 10000) entao
                    reajuste <- s_atual * 0.55
                    s_novo <- s_atual + reajuste
                    escreval ("Funcionário: ",funcionario)
                    escreval ("Você recebeu um reajuste de 55%, veja logo abaixo os dados")
                    escreval ("Salário atual: ",s_atual)
                    escreval ("Reajuste salarial: ",reajuste)
                    escreval ("Seu novo salário será: ",s_novo)
                    senao
                    se (s_atual >= 10000) e (s_atual <= 25000) entao
                                                                  reajuste <- s_atual * 0.30
                                                                  s_novo <- s_atual + reajuste
                                                                  escreval ("Funcionário: ",funcionario)
                                                                  escreval ("Você recebeu um reajuste de 30%, veja logo abaixo os dados")
                                                                  escreval ("Salário atual: ",s_atual)
                                                                  escreval ("Reajuste salarial: ",reajuste)
                                                                  escreval ("Seu novo salário será: ",s_novo)
                                                                  senao
                                                                  reajuste <- s_atual * 0.20
                                                                  s_novo <- s_atual + reajuste
                                                                  escreval ("Funcionário: ",funcionario)
                                                                  escreval ("Você recebeu um reajuste de 20%, veja logo abaixo os dados")
                                                                  escreval ("Salário atual: ",s_atual)
                                                                  escreval ("Reajuste salarial: ",reajuste)
                                                                  escreval ("Seu novo salário será: ",s_novo)
                    fimse

fimse

fimenquanto
fimalgoritmo
avatar
Tiago de Abreu
Ameba²
Ameba²

Mensagens : 25
Data de inscrição : 22/08/2011
Idade : 34

Ver perfil do usuário http://www.vlogdourbano.xpg.com.br

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Qui 8 Dez 2011 - 23:51

41) Calcular e imprimir X para X = A + B, enquanto A for positivo.

Código:
algoritmo "Caso A for positivo"
// Função :
// Autor :
// Data : 16/11/2011
// Seção de Declarações
var
a,b, x : inteiro
inicio
      escreva ("Digite um valor para A : ")
      leia (a)
      escreva ("Digite um valor para B : ")
      leia (b)
          enquanto A>0 faca
                    x <- A+B
                    EscrevaL ("x: B", x)
                    Escreva ("Escreva outro valor para A:")
                    leia (a)
                    Escreva ("Escreva outro valor para B:")
                    leia (b)
          fimenquanto
     
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:11

1- Construir um programa que efetue o cálculo do salário líquido de um professor. Sabendo-se que: - Salário Bruto = Horas Trabalhadas * Valor hora Aula; - Total de Desconto = (Percentual de Desconto / 100) * Salário Bruto; - Salário Líquido = Salário Bruto – Total de Desconto.

Código:
algoritmo "SárioLíquido"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
  HT, VHA, PD,D,SB,SL : real
inicio
      Escreva ("Digite as horas trabalhadas: ")
      leia (HT)
      Escreva ("Digite o valor da hora trabalhada: ")
      leia (VHA)
      SB <- HT*VHA
      Escreva ("Digite o percentual de desconto: ")
      leia (PD)
      D <- PD/100*SB
      SL <- SB-D
      EscrevaL ("O salário líquido é: ",SL)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:13

2- Escreva um programa que efetue o cálculo da quantidade de litros de combustível gastos em uma viagem, utilizando-se um automóvel que faz 12 Km por litro. Para obter o cálculo, o usuário deverá fornecer o tempo gasto na viagem e a velocidade média durante a mesma. Desta forma, será possível obter a distância percorrida com a fórmula DISTÂNCIA = TEMPO * VELOCIDADE. Tendo o valor da distância, basta calcular a quantidade de litros de combustível utilizada na viagem com a fórmula: LITROS_USADOS = DISTÂNCIA / 12. O programa deverá apresentar os valores da velocidade média, tempo gasto na viagem, a distância percorrida e a quantidade de litros utilizada na viagem.

Código:
algoritmo "ex2"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
  T,VM,D,LU : real
inicio
 Escreva ("Digite o tempo gasto: ")
 Leia (T)
 Escreva ("Digite a velocidade média: ")
 Leia (VM)
 D <- T*VM
 LU <- D/12
 LIMPATELA
 EscrevaL ("Tempo Gasto: ", T)
 EscrevaL ("Velocidade Média: ",VM)
 EscrevaL ("A distância é de ",D)
 EscrevaL ("A quantidade de litros usados é ",LU)
 
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:14

3- Faça um algoritmo para ler a base e a altura de um triângulo. Em seguida escreva a área do mesmo. Obs.: Área = ( Base * Altura ) / 2.

Código:
algoritmo "Ex3"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
Area,B,A : real
inicio
      Escreva ("Entre com a base do triângulo: ")
      Leia (B)
      Escreva ("Entre com a altura do triângulo: ")
      Leia (A)
      Area <- (B*A)/2
      EscrevaL (" A área do triângulo é de: ",Area)
     
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:16

4 - Desenvolva um programa que leia uma temperatura em graus Fahrenheit e apresente convertida em graus Centígrados. A fórmula de conversão é: C = (F - 32) * (5/9). Onde F é a temperatura em Fahrenheit e C é a temperatura em Centígrados.

Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
C,F : real
inicio
      Escreva ("Entre com a temperatura em Fahrenheit: ")
      Leia (F)
      C <-(F-32)*(5/9)
      EscrevaL ("A temperatura em Graus Centígrados é ",C)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:18

5- Dado um valor de venda (V), determinar o lucro líquido (LL), a comissão (C) e o lucro bruto (LB).
As fórmulas a serem usadas são :-
C = 0.10 * V
LB = 0.80 * ( V-C)
LL = 0.50 * LB
O valor da venda (V) será fornecido pelo usuário.

Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
V,LL,LB,C : real
inicio
      Escreva ("Digite o valor da venda: ")
      Leia (V)
      C <- 0.10*V
      LB <- 0.80*(V-C)
      LL <- 0.50*LB
      EscrevaL ("A comissão é de ",C)
      EscrevaL ("O Lucro Bruto é de ",LB)
      EscrevaL ("O valor líquido da venda é de ",LL)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:19

6- Faça um programa para calcular e exibir o volume de caixas usando a fórmula:-
VOLUME = COMPRIMENTO * LARGURA * ALTURA
Os valores de comprimento, largura e altura deverão ser fornecidos pelo usuário.

Código:
algoritmo "Ex6"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
V,C,L,A : real
inicio
      Escreva ("Digite o comprimento: ")
      Leia(C)
      Escreva ("Digite a largura: ")
      Leia(L)
      Escreva ("Digite a altura: ")
      Leia(A)
      V <- C*L*A
      EscrevaL (" O valor da caixa será de ",V)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:20

7- Escreva um programa para calcular Juros Simples através da fórmula:-
JUROS = CAPITAL * TAXA * TEMPO
Os valores de capital, taxa e tempo deverão ser fornecidos pelo usuário.

Código:
algoritmo "Ex7"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
J,C,TX,T : real
inicio
      Escreva ("Digite o capital: ")
      Leia (C)
      Escreva ("Digite a taxa: ")
      Leia (TX)
      Escreva ("Digite o tempo: ")
      Leia (T)
      J <- C*TX*T
      EscrevaL ("O juros será de ",J)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:22

8- Escreva um programa para calcular a área e o perímetro de um retângulo, dadas as medidas de seus lados:-
ÁREA = COMPRIMENTO * LARGURA PERÍMETRO = 2 * (COMPRIMENTO + LARGURA).

Código:
algoritmo "Ex8"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
 A,P,C,L : real
inicio
      Escreva ("Digite o comprimento do retângulo: ")
      Leia (C)
      Escreva ("Digite a largura do retângulo: ")
      Leia (L)
      A<-C*L
      P <- 2*(C+L)
      EscrevaL ("A área do retângulo será ",A)
      EscrevaL ("O perímetro do rentângulo será ",P)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:23

9- De acordo com os dados:- primeiro nome, ano de nascimento e o ano atual; calcular a sua idade.

Código:
algoritmo "Ex9"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
Nome : Caractere
N: inteiro
A: inteiro
I: inteiro
inicio
      Escreva ("Qual é o seu nome? ")
      Leia (Nome)
      Escreva ("Em que ano você nasceu? ")
      Leia (N)
      Escreva ("Digite em que ano estamos: ")
      Leia (A)
      I <- A-N
      Escreva ("Olá, ",Nome)
      EscrevaL("!")
      EscrevaL ("Sua idade é de ",I)

fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:26

10- Considerando que A:=5, B:=8 e C:=10 são os valores das variáveis, complete de forma que sejam calculadas as expressões:
X:= A + ( 2 * B ) / ( C – 6 )
Y := X * A

Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
A,B,C,X,Y : real
inicio
      A <- 5
      B <- 8
      C <- 10
      X <- A+(2*B)/(C-6)
      Y <- X* A
      EscrevaL ("As variáveis são:")
      EscrevaL ("A: ",A)
      EscrevaL ("B: ",B)
      EscrevaL ("C: ",C)
      EscrevaL ("")
      EscrevaL ("X = A+(2*B)/(C-6)")
      EscrevaL ("")
      EscrevaL ("O valor de x será: ",X)
      EscrevaL ("")
      EscrevaL ("Y = X*A")
      EscrevaL ("")
      EscrevaL ("O valor de y será: ",Y)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:27

11- Considere o algoritmo iniciado pelos comandos A:=1, B:=2 e C:=3, complete-o de modo que no final do algoritmo o conteúdo de A seja 3, de B seja 1 e de C seja 2.

Código:
algoritmo "Ex11"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
AUX,A,B,C : inteiro
inicio
      A <- 1
      B <- 2
      C <- 3
      Escreval ("As variáveis são")
      EscrevaL ("A:",A)
      EscrevaL ("B:",B)
      EscrevaL ("C:",C)
     
      AUX <- B
      B <- A
      A <- C
      C <- AUX
     
      EscrevaL ("Agora, as variáveis atribuiram o valor")
      EscrevaL ("A:", A)
      EscrevaL ("B:", B)
      EscrevaL ("C:", C)
     
     
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Letícia Ellen em Sex 30 Dez 2011 - 15:29

12- Preparar uma algoritmo para ler os lados de um triângulo ( S1, S2 e S3) e calcular a área de acordo com a fórmula:
Área = T(T – S1) (T – S2) (T – S3)
Onde: T = (S1 + S2 + S3)/2

Código:
algoritmo "Ex12"
// Função :
// Autor :
// Data : 29/08/2011
// Seção de Declarações
var
 S1,S2,S3,A,T : real
inicio
      Escreva ("Digite S1: ")
      Leia (S1)
      EScreva ("Digite S2: ")
      Leia (S2)
      EScreva ("Digite S3: ")
      Leia (S3)
      T <- (S1+S2+S3)/2
      A <- T*(T-S1)*(T-S2)*(T-S3)
      EscrevaL ("A área do triângulo é ",A)
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: ALGORITMOS DADOS EM SALA "EXERCÍCIOS"

Mensagem  Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum