Resoluções de Provas

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resoluções de Provas

Mensagem  Tiago de Abreu em Qua 26 Out 2011 - 3:05

Neste Tópico vamos postar nossas resoluções... cada um vai ter um solução diferente.... ou similar... é muito importante ver como um mesmo problema é resolvido de maneiras diferentes... com mais ou menos linhas de programação ou declaração de variáveis... então para darmos continuidade respondam sempre esse tópico!!! ok!!!! Vamos para o que interessa!!! abraço a todos...




Última edição por Tiago de Abreu em Sex 11 Nov 2011 - 4:11, editado 2 vez(es)
avatar
Tiago de Abreu
Ameba²
Ameba²

Mensagens : 25
Data de inscrição : 22/08/2011
Idade : 35

Ver perfil do usuário http://www.vlogdourbano.xpg.com.br

Voltar ao Topo Ir em baixo

Resolução Correta - Exercício 2 - Prova 25/10/2011

Mensagem  Tiago de Abreu em Qui 27 Out 2011 - 18:56

Resolução

Código:


algoritmo "Exercício 2 - Prova"
// Função :
// Autor : Tiago de Abreu
// Data : 25/10/2011
// Seção de Declarações
var
A,B,C,valor1,valor2,valor3:inteiro
inicio
// Seção de Comandos
escreval ("---------------------------------------------------------------------------------")
escreval ("                      Se valores formam um Triangulo                            ")
escreval ("---------------------------------------------------------------------------------")
escreva ("Por Favor, Digite 1º Valor disdinto: ")
leia (valor1)
limpatela
escreva ("Por Favor, Digite 2º Valor distinto: ")
leia (valor2)
limpatela
escreva ("Por Favor, Digite 3º Valor distinto: ")
leia (valor3)
limpatela
se  valor1 > valor2  entao
                      se valor1 > valor3  entao
                                          A<-valor1
                                          B<-valor2
                                          C<-valor3
                                          senao
                                          A<-valor3
                                          B<-valor1
                                          C<-valor2
                      fimse
                     
                    senao
                      se valor2 > valor1  entao
                                          se valor2 > valor3  entao
                                                                A<-valor2
                                                                B<-valor1
                                                                C<-valor3
                                                              senao
                                                                A<-valor3
                                                                B<-valor1
                                                                C<-valor2
                                          fimse
                      fimse
fimse
se A<B+C entao
          escreval("A: ",A)
          escreval("B: ",B)
          escreval("C: ",C)
          escreval("Esses valores formam um triângulo")
        senao
          escreval("A: ",A)
          escreval("B: ",B)
          escreval("C: ",C)
          escreval("Esses valores não formam um triângulo")
fimse
fimalgoritmo


Última edição por Tiago de Abreu em Sex 11 Nov 2011 - 4:12, editado 2 vez(es)
avatar
Tiago de Abreu
Ameba²
Ameba²

Mensagens : 25
Data de inscrição : 22/08/2011
Idade : 35

Ver perfil do usuário http://www.vlogdourbano.xpg.com.br

Voltar ao Topo Ir em baixo

Minha resolução da Prova

Mensagem  Letícia Ellen em Ter 8 Nov 2011 - 15:40

A resolução que eu fiz ficou bem parecida com a sua, mas eu coloquei a saída fora do Se Smile



avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Legal!!! Gostei!

Mensagem  Tiago de Abreu em Qui 10 Nov 2011 - 5:08

Letícia Ellen escreveu:A resolução que eu fiz ficou bem parecida com a sua, mas eu coloquei a saída fora do Se Smile


É isso mesmo!!! testei aqui e rodou legal sua resolução!!! o resto do pessoal da sala poderia postar tb!!!!

VALEU!
avatar
Tiago de Abreu
Ameba²
Ameba²

Mensagens : 25
Data de inscrição : 22/08/2011
Idade : 35

Ver perfil do usuário http://www.vlogdourbano.xpg.com.br

Voltar ao Topo Ir em baixo

Revisão

Mensagem  Leonardo Pereira em Sab 12 Nov 2011 - 0:49

Esta é a minha resolução do problema. Vejam o que acham.
Código:

algoritmo "90graus"
var
a,b,c,x,y,z:inteiro
inicio
escreva("Favor, digite um número e tecle enter: ")
leia(x)
escreva("Agora digite mais um número: ")
leia(y)
escreva("Digite o último número agora: ")
leia(z)
limpatela
se (x>y) e (x>z) entao
              a<-x
              b<-y
              c<-z
            senao
              se (y>x) e (y>z) entao
                              a<-y
                              b<-z
                              c<-x
                            senao
                              a<-z
                              b<-x
                              c<-y
              fimse
fimse
escreval("Os valores são: ")
escreval(a)
escreval(b)
escreval(c)
escreval("")
escreval("")
se a<(b+c) entao
            escreval("Esses valores formam um triângulo.")
          senao
            escreval("Esses valores não formam um trinângulo.")
fimse
escreval("")
escreval("")
escreval("--------------------------------------------------------")
escreval("            Obrigado por usar 90Graus                  ")
escreval("--------------------------------------------------------")
fimalgoritmo
avatar
Leonardo Pereira
Ameba
Ameba

Mensagens : 23
Data de inscrição : 03/11/2011
Idade : 32
Localização : Americana - SP

Ver perfil do usuário http://pressupostopeculiar.blogspot.com/

Voltar ao Topo Ir em baixo

Prova - 23/11/11

Mensagem  Tiago de Abreu em Qui 24 Nov 2011 - 2:49

01)Seja P1 a medida do nível de poluição do ar. A qualidade do ar é medida em função de P1. Elaborar um algoritmo que leia o nível de poluição do ar e imprima o nome da localidade e a qualidade do ar de cada localidade. Considere que teremos uma determinada quantidade de localidades onde esse número é fornecido na entrada.
Nível de poluição / Qualidade do ar
P1<=100 - Ótima
100<P1<=200 - Boa
200<P1<=300 - Regular

Código:

algoritmo "semnome"
// Função :
// Autor :
// Data : 23/11/2011
// Seção de Declarações
var
P1:real
qlocal,cont:inteiro
qualidade,localidade:caracter
inicio
// Seção de Comandos

escreva ("Digite nº de localidades: ")
leia (qlocal)
enquanto cont < qlocal faca
cont<- cont + 1
escreva ("Digite o nome da Localidade: ")
leia (localidade)
escreva ("Digite o nível de poluição: ")
leia (P1)
se P1 < 100 entao
              qualidade <- "ótima"
              escreval ("Em ",localidade)
              escreval ("A qualidade do ar é: ",qualidade)
            senao
              se P1 <= 200 entao
                            qualidade <- "Boa"
                            escreval ("Em ",localidade)
                            escreval ("A qualidade do ar é: ",qualidade)
                            senao
                            qualidade <- "Regular"
                            escreval ("Em ",localidade)
                            escreval ("A qualidade do ar é: ",qualidade)
              fimse
fimse
                           
fimenquanto
fimalgoritmo


02)Escreva um algoritmo que leia seu nome e repita dez vezes. (use laços)

Código:

algoritmo "semnome"
// Função :
// Autor :
// Data : 23/11/2011
// Seção de Declarações
var
nome:caracter
x:inteiro
inicio
// Seção de Comandos

escreva ("Digite seu nome completo: ")
leia (nome)
enquanto x < 10 faca
x<- x + 1
escreval (x," - ",nome)

fimenquanto
fimalgoritmo


03)Escreva um Algoritmo que imprima de 0 a 100 somente os números pares.

Código:

algoritmo "semnome"
// Função :
// Autor :
// Data : 23/11/2011
// Seção de Declarações
var
x:inteiro
inicio
// Seção de Comandos

enquanto x < 100 faca
x<- x + 2
escreva (x, " - ")

fimenquanto
fimalgoritmo
Código:


Última edição por Tiago de Abreu em Qui 24 Nov 2011 - 5:41, editado 1 vez(es)
avatar
Tiago de Abreu
Ameba²
Ameba²

Mensagens : 25
Data de inscrição : 22/08/2011
Idade : 35

Ver perfil do usuário http://www.vlogdourbano.xpg.com.br

Voltar ao Topo Ir em baixo

Perguntas da prova - 23/11/2011

Mensagem  Letícia Ellen em Qui 24 Nov 2011 - 3:45

Perguntas
1) Seja P1 a medida do nível de poluição do ar. A qualidade do ar é medida em função de P1. Elaborar um algoritmo que leia o nível de poluição do ar e imprima o nome da localidade e a qualidade do ar de cada localidade. Considere que teremos uma determinada quantidade de localidades onde esse número é fornecido na entrada.
Nível de poluição / Qualidade do ar
P1<=100 - Ótima
100<P1<=200 - Boa
200<P1<=300 - Regular

2) Elabore um algoritmo que imprima os números pares de 0 a 100.


3) Elaborar um algoritmo que imprima o seu nome completo dez vezes na tela.


Última edição por Letícia Ellen em Qui 24 Nov 2011 - 4:06, editado 2 vez(es)
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Resoluções de Provas

Mensagem  Letícia Ellen em Qui 24 Nov 2011 - 3:48

1)
Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 23/11/2011
// Seção de Declarações
var
x, qp: inteiro
local, texto: caracter
p1 : real
inicio
      Escreva ("Por favor, digite a quantidade de localidades: ")
      Leia (qp)
      Escreva ("Digite a localidade: ")
      Leia (local)
      Escreva ("Digite o nível de poluição: ")
      Leia (p1)
      para x de 1 ate qp-1 faca
      se p1 <=100 entao
        texto <-"ótima"
      senao
          se p1<=200 entao
              texto <- "boa"
          senao
              texto <- "regular"
          fimse
      fimse
      Limpatela
      EscrevaL ("A seguinte localidade: ",local)
      EscrevaL ("apresentou ", texto," qualidade do ar")
      EscrevaL ("")
      Escreva  ("Digite a localidade: ")
      Leia (local)
      Escreva  ("Digite o nível da poluição: ")
      Leia (p1)
      fimpara
     
fimalgoritmo



Última edição por Letícia Ellen em Qui 24 Nov 2011 - 3:59, editado 1 vez(es)
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Resoluções de Provas

Mensagem  Letícia Ellen em Qui 24 Nov 2011 - 3:58

3)
Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 23/11/2011
// Seção de Declarações
var
n: caracter
x :inteiro
inicio
      Escreva ("Insira o seu nome completo: ")
      Leia (n)
      para x de 1 ate 10 faca
          Limpatela
          EscrevaL (n)
      fimpara
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Resoluções de Provas

Mensagem  Letícia Ellen em Qui 24 Nov 2011 - 4:04

2)
Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 23/11/2011
// Seção de Declarações
var
n : inteiro
inicio
      n <- 0
      enquanto n <= 98 faca
              n <- n+2
              EscrevaL(n)

      fimenquanto
fimalgoritmo
avatar
Letícia Ellen
Ameba²
Ameba²

Mensagens : 34
Data de inscrição : 27/10/2011
Idade : 24
Localização : Americana, São Paulo, Brasil

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Número 3 da Prova: y=x²+2x

Mensagem  Leonardo Pereira em Qui 1 Dez 2011 - 2:17

Código:

algoritmo "Expressão"
var
x,y,c,v:inteiro
inicio
escreval("Vamos calcular a expressão y=x²+2x para onze valores de x")
x<-10
y<-0
c<-0
v<-1
    enquanto c<11 faca
      y<-(x*x)+(2*x)
      escreval("Para o valor de x= ",x)
      escreval("O valor de y é ",y)
      x<-x+v
      c<-c+1
    fimenquanto
  escreval("")
  escreval("--------------------------")
  escreval("Obrigado por usar a cabeça")
  escreval("Expressão a melhor opção")
  escreval("--------------------------")
fimalgoritmo

Essa foi minha tentativa, espero que vcs gostem! ( E o professor tbm!)
avatar
Leonardo Pereira
Ameba
Ameba

Mensagens : 23
Data de inscrição : 03/11/2011
Idade : 32
Localização : Americana - SP

Ver perfil do usuário http://pressupostopeculiar.blogspot.com/

Voltar ao Topo Ir em baixo

Re: Resoluções de Provas

Mensagem  Thiago Ludugero em Qui 1 Dez 2011 - 21:08

Legal Leonardo.. rodei o seu aqui.. Rodou certinho..
o meu ficou um pouco diferente, mas esqueci de trazer pra testar..
nem sei se está certo ;D
avatar
Thiago Ludugero
Ameba
Ameba

Mensagens : 9
Data de inscrição : 09/08/2011
Idade : 28
Localização : Americana - SP

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Posta aí..

Mensagem  Leonardo Pereira em Sab 10 Dez 2011 - 15:50

Thiago Ludugero escreveu:Legal Leonardo.. rodei o seu aqui.. Rodou certinho..
o meu ficou um pouco diferente, mas esqueci de trazer pra testar..
nem sei se está certo ;D


Blz! Posta o seu depois pra gente testar, como ficou diferente é bom para comparar.
Falou.
afro
avatar
Leonardo Pereira
Ameba
Ameba

Mensagens : 23
Data de inscrição : 03/11/2011
Idade : 32
Localização : Americana - SP

Ver perfil do usuário http://pressupostopeculiar.blogspot.com/

Voltar ao Topo Ir em baixo

Re: Resoluções de Provas

Mensagem  Thiago Ludugero em Seg 12 Dez 2011 - 23:32

Eu nem lembro como ficou o meu... e nao fui pegar minha prova com o Zé..
Razz
avatar
Thiago Ludugero
Ameba
Ameba

Mensagens : 9
Data de inscrição : 09/08/2011
Idade : 28
Localização : Americana - SP

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Hehe

Mensagem  Leonardo Pereira em Ter 20 Dez 2011 - 17:10

farao Falou então, hehe
Agora vc não pega mais.. haha lol!

santa rendeer santa king santa study
avatar
Leonardo Pereira
Ameba
Ameba

Mensagens : 23
Data de inscrição : 03/11/2011
Idade : 32
Localização : Americana - SP

Ver perfil do usuário http://pressupostopeculiar.blogspot.com/

Voltar ao Topo Ir em baixo

Re: Resoluções de Provas

Mensagem  Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum